Did apple finally admit security breach ?

Apple Update

 

Over a week the headlines we see is only about the celebrities’ nudes’ pictures that was leaked. We came and realized that some of the some of the celebrities were using Icloud. Applied said it was a security breach it was just random accounts that were hacked. But this week applied update on it’s current operating system. According to there website the new website comprise of the following features:

 

For the protection of our customers, Apple does not disclose, discuss, or confirm security issues until a full investigation has occurred and any necessary patches or releases are available. To learn more about Apple Product Security, see the Apple Product Security website.

For information about the Apple Product Security PGP Key, see How to use the Apple Product Security PGP Key.

Where possible, CVE IDs are used to reference the vulnerabilities for further information.

To learn about other Security Updates, see Apple Security Updates.

OS X Server v3.2.1

  • CoreCollaboration

Available for: OS X Mavericks v10.9.5 or later

Impact: A remote attacker may be able to execute arbitrary SQL queries

Description: A SQL injection issue existed in Wiki Server. This issue was addressed through additional validation of SQL queries.

  • CVE-ID

CVE-2014-4424 : Sajjad Pourali (sajjad@securation.com) of CERT of Ferdowsi University of Mashhad

  • CoreCollaboration

Available for: OS X Mavericks v10.9.5 or later

Impact: Visiting a maliciously crafted website may lead to the execution of arbitrary JavaScript

Description: A cross-site scripting issue existed in Xcode Server. This issue was addressed through improved encoding of HTML output.

CVE-ID

CVE-2014-4406 : David Hoyt of Hoyt LLC

  • CoreCollaboration

Available for: OS X Mavericks v10.9.5 or later

Impact: Multiple vulnerabilities in PostgreSQL, the most serious of which may lead to arbitrary code execution

Description: Multiple vulnerabilities existed in PostgreSQL. This issue was addressed by updating PostgreSQL to version 9.2.7.

CVE-ID

CVE-2014-0060

CVE-2014-0061

CVE-2014-0062

CVE-2014-0063

CVE-2014-0064

CVE-2014-0065

CVE-2014-0066

 

 

0 replies

Leave a Reply

Want to join the discussion?
Feel free to contribute!

Leave a Reply

Your email address will not be published. Required fields are marked *